Joerg´s IT-Tech Blog

Microsoft Technologien und über den Tellerrand hinaus, Aber vorher das TESTEN nicht vergessen!

Posts Tagged ‘OWA’

Exchange 2010 OWA: Das Postfach auf das Sie zugreifen möchten ist nicht verfügbar

Posted by JoergS - 11. September 2012

Hi,

bei meinem Kunden, erhalten Benutzer z.t. eine Fehlermeldung, wenn sie über OWA auf Shared Mailboxen zugreifen.

Fehler:

Exchange 2010 OWA: Das Postfach auf das Sie zugreifen möchten ist nicht verfügbar

oder

Your mailbox appears to be unavailable. Try to access it again in 10 seconds. If you see this error again, contact your helpdesk.

Lösung:

Verschieben der Datenbank mit den Shared Mailboxen vom EX2010-DAGNode1 auf EX2010-DAGNode2

Denn Exchange 2010 SP2 inkl. RU3 ist installiert (KB2489822 trifft nicht zu), der Microsoft Exchange Information Store lief auch (http://jaliyaudagedara.blogspot.de/2011/02/error-your-mailbox-appears-to-be.html)

Na dann, Viel Spass beim selber Testen!
CU

Advertisements

Posted in Exchange, Fehler | Verschlagwortet mit: , , , , , , | Leave a Comment »

Exchange 2010 SP2 und Lync 2010 OWA/Outlook Web App Integrations Fehler

Posted by JoergS - 16. Februar 2012

Hi,

Wahrscheinlich durch die neusten Windows Updates war einfach keine Kommunikation mehr zwischen Exchange CAS und Lync FE da. Sonst bekommt man ja wenigstens einen Fehler dass kein IM Dienst zur Verfügung steht im OWA. Diesmal war die Integration einfach weg. Es waren auch keine Fehler im Eventlog, was sehr danach aussah als ob der Exchange CAS gar nicht mehr mit dem Lync FE spricht.
Ich musste heute daher bei uns die Lync/OWA Integration neu installieren, also die Lync Server 2010 R2 Web Service Provider.
Also habe ich die WebService Provider auf dem Exchange CAS deinstalliert und dann wie hier (http://technet.microsoft.com/en-us/library/gg420962.aspx) in Step1 beschrieben. Die UCManged API 2.0 konnte gar nicht installiert werden, bevor nicht die alte API deinstalliert war.

CWAOWASSP.msi konnte ich erst auch nicht installieren, hab dann im Eventlog den Restart/Session Manager gesehen und den Pending Reboot Reg key gelöscht.

Dann noch den Reg-Key und die DLL geprüft.

Dann ging auch die OWA/Lync Integration wieder.

Na dann, Viel Spass beim selber Testen!
CU

Posted in Exchange, Fehler, Probleme, UC | Verschlagwortet mit: , , , , | Leave a Comment »

Alice Outlook Exchange migriert zu O2

Posted by JoergS - 19. Januar 2012

Hi,

Telefonica O2 hat ja Hansenet aus Hamburg gekauft und somit auch die Produkte um Alice DSL übernommen.

In meinem Alice Comfort Anschluss ist auch ein Outlook Web Access/Exchange Konto enthalten. Leider noch ein Exchange Server 2003 und kein RPC-over-HTTPS, sondern nur IMAP Zugriff per Outlook möglich. Alles weiter muss dann über das Outlook Web Access erledigt werden.

Nun wurde in diesen Tagen die Migration von Alice zu O2 vollzogen und weder mein Outlook, noch mein Windows Phone 7 konnte sich mit dem Exchange Server verbinden. Es wurde immer ein falsches SSL-Zertifikat angemeckert.

Auflösung brachte dann die Suche im Hansenet-User-Forum und diesem Thread. Dort erhält man unter dem link https://webmail.alice.de zu griff auf sein OWA (Umleitung auf https://dsl.o2online.de/selfcare/content/segment/kundencenter/onlinespeicher/webmail/).

In der Hilfe für Push-Mail ist dann auch beschrieben, dass der Server geändert wurde (NICHT die Hilfe für Smartphone, dort ist noch der alte Servername drin!), die neuen Einstellungen sind:

Serveradresse/-Name: „mailstore.dsl.o2online.de“ -> hier war alt: „maistore.alice-dsl.de“
Verschlüsselung (SSL): aktiviert
Benutzername: Ihre vollständige E-Mail-Adresse, z. B. kurt.kunde@alice-dsl.net oder kurt.kunde@alice.de
Kennwort: Ihr E-Mail-Passwort
Domäne: hsn.alice-dsl.net

Na dann, Viel Spass beim selber Testen!
CU

Posted in Allgemeines, Exchange, Fehler, Neuerungen, Probleme | Verschlagwortet mit: , , , , , , , , | 1 Comment »

Exchange Server 2010 SP2 ist verfügbar

Posted by JoergS - 5. Dezember 2011

Hi,

Microsoft hat das Service Pack 2 für Exchange Server 2010 zum Download zur Verfügung gestellt.

Neu im SP2 ist:

  • Hybrid Configuration Wizard: für Cloud und On-Premise Deployments
  • Cross-Site Silent Redirection für Outlook Web App
  • Outlook Web App Mini: Browser-basierte Version von OWA für niedrige Bandbreiten, was ehemals OMA hieß (Outlook Mobile Access)
  • GAL Segmentation/Adress Book Policies

Das Service Pack 2 benötigt in der Webserver Rolle die Kompnenten “IIS 6 WMI Compatibility” bei  Servern mit der CAS Rolle.

Ebenso ist im Exchange 2010 SP2 eine Schema Erweiterung enthalten, es muss also im AD-Forest mit Schema/Organisationsadmin Rechten die Schema Updates zuerst installiert werden

Nachzulesen auch hier:

Na dann, Viel Spass beim selber Testen!
CU

Posted in Exchange, Neuerungen, Neuigkeiten | Verschlagwortet mit: , , , , | Leave a Comment »

Fehler in Outlook Web App (OWA) Einstellungen nach Exchange SP1 Install

Posted by JoergS - 26. Februar 2011

Hi,

wenn man nach dem Install des Exchange 2010 SP1, beim Aufruf der OWA Optionen den Fehler 400 "Bad Request" erhält, liegt das an den nicht gesetzten MailboxRegionalConfiguration der Usermailbox.

get-MailboxRegionalConfiguration -Identity username| fl

MailoxRegionalConfiguration01

Dazu per Exchange-Powershell folgenden Befehl absetzen:

Set-MailboxRegionalConfiguration -Identity username -Language de-de -TimeZone "W. Europe Standard Time"

Danach sind die Einstellungen gesetzt:

MailoxRegionalConfiguration02

Und man kann im OWA auch die Optionen aufrufen

MailoxRegionalConfiguration03

Na dann, Viel Spass beim selber Testen!
CU

Posted in Exchange, Fehler | Verschlagwortet mit: , , , , | Leave a Comment »

Lync 2010: Praxis Tipps zum Deployment

Posted by JoergS - 31. Januar 2011

Hi,

nach unserer erfolgreichen Installation von Microsoft Lync Server 2010 letztes Wochenende hier ein paar Tipps, die vielleicht ein paar Stolpersteine verhindern …

FQDN´s verwenden!!!

  • Bei Servernamen und Poolnamen und immer FQDN´s verwenden (lyncserver1.intdomain.tld und lyncpool.intdomain.tld)

Zertifikate: http://technet.microsoft.com/en-us/library/gg398066.aspx

  • Für alle Lync Server, egal ob Front-End, Edge, Mediation, A/V usw. immer Client- (Client) und Server Authorizsation (Server EKU) Zertifikate austellen.
  • Am besten auch SAN-Zertifikate verwenden, also mit Subject Alternative Names
    Für Internal-Server (servername.intdomain.tld, lyncpool.intdomain.tld, sip.intdomain.tld, dialin.intdomain.tld, meet.intdomain.tld, sip.extdomain.tld, dialin.extdomain.tld, meet.extdomain.tld), http://technet.microsoft.com/en-us/library/gg398094.aspx
  • Die private Keys der Zertifikate müssen exportierbar sein!

Lync Share: http://technet.microsoft.com/en-us/library/gg425852.aspx

  • Das Share darf NICHT auf einem der Lync Server selbst liegen!
  • Die Share- UND NTFS-Berechtigungen prüfen!

Lync 2010 Integration mit Exchange 2010: http://blogs.technet.com/b/ilvancri/archive/2010/09/22/configuring-exchange-2010-sp1-and-lync-rc-to-enable-owa-as-lync-endpoint.aspx

  • Nur mit Exchange 2010 SP1!
  • nach Erstellung des Trusted Application Pool, die Replikation ausschalten!

Na dann, Viel Spass beim selber Testen!
CU

Posted in UC | Verschlagwortet mit: , , , , , | Leave a Comment »

Demo Umgebung Part 6 Exchange 2007 OWA Publishing mit ISA Server 2006

Posted by JoergS - 24. September 2009

Hi,

wie schon in meinen letzten 5 Artikeln meiner Demo Umgebung nun mein nächster Artikel.

Dieses mal zum Thema Exchange 2007 Outlook Web Access (OWA) Publishing mit ISA Server 2006, womit ich von extern per Browser über HTTPS meine bestehende Demo Umgebung auch von außer Testen kann für Mail Verkehr.

Als erstes bereite ich den Exchange 2007 mit der CAS-Server Rolle auf seine Aufgabe vor, OWA Verbindungen anzunehmen. Dazu wählt man in der Exchange Management Console die “Server Configuration” und dort “Client Access”. Gleich auf der ersten Registerkarte steht OWA, was man mit der rechten Maustaste und “Properties” konfiguriert. So muss man eine URL eingegeben und die Authentifizierungsmethode z.B. “Form-based Authentification” auswählen. Weiterhin kann man noch den Zugriff auf OWA Elemente oder den Zugriff von öffentlichen/privaten Computern einschränken bzw. auch den Zugriff auf Remote File Sharing Server zulassen bzw. verweigern.

Zunächst erstelle ich mir ein SSL-Zertifikat für den externen DNS Name oder beantrage es von einer 3rd Party Zertifizierungsstelle (CA) (z.B. Thawte oder Verisign). Da es sich bei mir nur um Demo handelt erstelle ich ein internes Webserver Zertifikat, was meine interne Demo RootCA ausstellt und signiert. Dieses SSL-Webserver muss man dann in den internen Zertifikatsspeicher des ISA Server importieren und zwar in “Eigenen Zertifikate” des Computers (!), nicht des Benutzers. Natürlich sollte im Zertifikatsstore “Vertrauenswürdige Zertifizierungsstellen” das RootCA Zertifikat des internen CA liegen.

Nun folgt als nächstes die Erstellung des OWA HTTPS Listeners. Man vergibt einen Namen z.B. OWA HTTPS Listener und wählt “Require SSL secured connections with clients” aus. Auf der nächsten Seite wählt man die externe IP aus, auf die der ISA Server HTTPS anfragen zu OWA entgegen nehmen soll und weißt dem Listener, als nächstes das eben erstellte SSL-Webserver Zertifikat zu. Als Letztes wählt man noch die als Authentication Settings “Form-based Authentication” mit Active Directory aus. Somit erhält man beim Aufruf der OWA Seite ein Exchange 2007 Anmeldeformular zur Eingabe von Usernamen und Passwort, natürlich alles über SSL (HTTPS) abgesichert. Single Sign On (SSO) aktiviere ich nicht, da ich es in meinem Szenario nicht benötige.

Jetzt erstelle ich erst die eigentliche OWA Publishing Rule und wähle meine Exchange Server Version 2007 und “Publish single Web site” aus. Ebenso wie im Listener wähle ich auch hier “Use SSL to connect to published Web Server” aus und definiere auf der nächsten Seite meinen internen Exchange Server mit FQDN, also Ex07.demo.local. Auf der nächsten Seite definiere ich den externen DNS Namen unter dem ich OWA erreichen möchte, welche natürlich derselbe wie im zuvor ausgestellten SSL-Zertifikat sein muss. Nun folgt die Auswahl des zuvor angelegten OWA HTTPS Listeners, welche auch gleicht prüft, ob der DNS Name mit dem SSL-Zertifkat übereinstimmt. Nun folgt noch die Auwahl der Authentication Delegation, “Basic (HTTP)”. Wer jetzt Angst hat dass dann ja die Kennwort in Klartext übermittelt werden, brauch an dieser Stelle keine Angst haben, denn die Verbindung ist ja per SSL (HTTPS) verschlüsselt. Als letztes sucht man noch die Gruppe der User aus, die sich per ISA anmelden und OWA nutzen darf, in der Regel sind das nur "Authentifizierte User” oder eine spezielle OWA-Gruppe.

Nun kann man per Browser in OWA seine E-Mails von jedem Rechner der Welt auch einsehen und verschicken!

Hier noch ein paar Impressionen des ISA 2006 OWA Publishing:

Na dann, Viel Spass beim selber Testen!
CU

Posted in Edge, Exchange, Forefront | Verschlagwortet mit: , , , , | Leave a Comment »

Forefront IAG: Fehler beim Veröffentlichen eines deutschen Exchange OWA Kalenders

Posted by JoergS - 10. August 2009

Hi,

Faisal Hussain hat eine Anleitung geschrieben für einen Fehler, der beim Veröffentlichen eines deutschen Exchange OWA Kalenders über das IAG auftreten kann.

When you publish German or any Double Byte language Exchange through IAG , you might see the following error when accessing the OWA Calender page:

<snip>

Webpage error details

Message: Access is denied to: https://ac.cdf.local/whalecom81249048fa132e49dd8c0987588586c1e640607057125a3787b/whalecom1/exchweb/6.5.6944.0/controls/ctrl_message.ht

Line: 0

Char: 0

Code: 0

URI: https://xy2.bcd.at/whalecom81249048fa132e49dd8c0987588586c1e640607057125a3787b/whalecom1/exchange/Administrator/Kalender/?Cmd=new&mm=7&dd=29&yy=2009

Message: Access is denied to: https://ac.cdf.local/whalecom81249048fa132e49dd8c0987588586c1e640607057125a3787/whalecom1/exchweb/6.5.6944.0/controls/ctrl_datepicker.htc

Line: 0

Char: 0

Code: 0

URI: https://xy2.bcd.at/whalecom81249048fa132e49dd8c0987588586c1e640607057125a3787/whalecom1/exchange/Administrator/Kalender/?Cmd=new&mm=7&dd=29&yy=2009

Message: Object doesn’t support this property or method

Line: 268

Char: 2

Code: 0

URI: https://xy2.bcd.at/whalecom81249048fa132e49dd8c0987588586c1e640607057125a3787/whalecom1/exchweb/6.5.6944.0/controls/ctrl_message.js

</snip>

After investigating the following workaround has been found to resolve this error and it actually works fine. But the correct way is not to modify the actual WhlFiltSecureRemote_HTTPS.xml but create a CustomUpdateable file. Anyways just to give you an idea here is it how the above error is fixed:

C:\Whale-Com\e-Gap\von\conf\SRATemplates\WhlFiltSecureRemote_HTTPS.xml

Ø  and then try these steps and let me know the results:

Please open this file in notepad (ensure you don’t break it as its xml file> à

C:\Whale-Com\e-Gap\von\conf\SRATemplates\WhlFiltSecureRemote_HTTPS.xml

and and very carefully only change the following  :

            <APPLICATION>

                                   <APPLICATION_TYPE>OWA2003SP1</APPLICATION_TYPE>

                                   <URL>/exchange/.*/Inbox/.*\.EML\?cmd=preview</URL>

                                   <URL>.*\.EML.*</URL>

                                   <URL>.*(Calendar|Contacts|Tasks)</URL>

            </APPLICATION>

to

            <APPLICATION>

                                   <APPLICATION_TYPE>OWA2003SP1</APPLICATION_TYPE>

                                   <URL>/exchange/.*/Inbox/.*\.EML\?cmd=preview</URL>

                                   <URL>.*\.EML.*</URL>

                                   <URL>.*(Kalender|Kontakte|Aufgaben)</URL>

                                    <URL>.*(Calendar|Contacts|Tasks)</URL>  

            </APPLICATION>

// if you notice that I have added English Calendar after German and by doing this you ensure that in multiligual environment if someone has english OWA then that should also work with German or any other european langauges.

Uncode or double Byte language calendar breaks via IAG

Na dann, Viel Spass beim selber Testen!
CU

Posted in Edge, Exchange, Forefront, Probleme | Verschlagwortet mit: , , , , | Leave a Comment »

1&1 Outlook Web Access (OWA – Hosted Exchange) Login Problem

Posted by JoergS - 11. April 2009

Hi,

ich hatte das Problem, dass ich mich in mein 1&1 Outlook Web Access (OWA – Hosted Exchange) nicht einloggen konnte. Der Benutzername und das Passwort war auch richtig, denn ich habe keine Fehlermeldung bzgl. dessen erhalten. Der Test unter mehreren Browsern wie IE6, IE7, IE8 und auch Firefox brachte auch keine Abhilfe. Auch der 1&1 Support konnte mir bei dem Problem nicht weiterhelfen.

Also bin ich selbst auf Fehlersuche gegangen und habe die Lösung eigentlich per Zufall rausgefunden:

  1. Man muss sich beim ersten OWA Login vorher im 1&1 Control Center einloggen (KNR, Domain oder Benutzernamme +  Passwort)
  2. Gleich im Start des Control Center wählt man dann 1&1 Outlook Exchange
  3. Im Outlook Exchange Bereich klickt man dann auf den http(s)://profimailer.de Link
  4. es öffnet sich der OWA Login und loggt sich dann mit seiner E-Mail und Passwort ein und bekommt auch sein Postfach zu sehen

Meine Vermutung ist das ein 1&1 Cookie auf dem Rechner fehlt, weshalb der erste Login nicht funktioniert und nach dem Control Center Login dieser Cookie vorhanden ist. Das ganze auch mal als Video und Screenshots:

Na dann, Viel Spass beim selber Testen!
CU

Posted in Exchange, Probleme | Verschlagwortet mit: , , , , | Leave a Comment »

 
%d Bloggern gefällt das: